Crypto Withdrawal is in degraded performance
Incident Report for VirgoCX
Resolved
This incident has been resolved.
Posted May 18, 2023 - 23:30 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 18, 2023 - 20:29 EDT
This incident affected: Crypto Withdrawal (ATOM, BCH, BTC, DOGE, ETC, ETH-ERC20, LTC, XLM, LUNA2).