Auto Individual verification is in maintenance
Incident Report for VirgoCX
Resolved
This incident has been resolved.
Posted Jul 06, 2023 - 17:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 06, 2023 - 11:07 EDT
This incident affected: Verification (Individual verification).